Bug, with fonts when OXT is open.

Organizing tasks to work on, New Features Ideas, Building LCS & LCB Libraries & Widgets, Redecorating and Modifying the IDE, Hacking / Editing Tools, Compiling the Engine from Source, etc.
Post Reply
User avatar
tperry2x
Posts: 1173
Joined: Tue Dec 21, 2021 9:10 pm
Location: Britain (Previously known as Great Britain)
Contact:

Bug, with fonts when OXT is open.

Post by tperry2x »

I'm not sure if this happens with the Mac version of OXT, and if anyone can test in Windows to see if they can replicate it.

I'm currently using MX Linux, and have found I can produce a crash in OXT this way:
If you have OXT open, and you have any stack open.

If you manually copy a font into ~/.fonts, or perhaps remove a font from ~/.fonts, soon afterwards, OXT will just quit unexpectedly with no warning or notification. Gone.

Tried this and can reproduce this behaviour with multiple fonts. In short, mess around adding TTF or OTF fonts into your home, fonts folder and does OXT crash for anyone else?
User avatar
OpenXTalkPaul
Posts: 1355
Joined: Sat Sep 11, 2021 4:19 pm
Contact:

Re: Bug, with fonts when OXT is open.

Post by OpenXTalkPaul »

tperry2x wrote: Fri Mar 10, 2023 7:33 pm I'm not sure if this happens with the Mac version of OXT, and if anyone can test in Windows to see if they can replicate it.

I'm currently using MX Linux, and have found I can produce a crash in OXT this way:
If you have OXT open, and you have any stack open.

If you manually copy a font into ~/.fonts, or perhaps remove a font from ~/.fonts, soon afterwards, OXT will just quit unexpectedly with no warning or notification. Gone.

Tried this and can reproduce this behaviour with multiple fonts. In short, mess around adding TTF or OTF fonts into your home, fonts folder and does OXT crash for anyone else?
Interesting, thanks for the testing and sleuth work. Generally still tend to relaunch apps when I add a bunch of fonts to the system (mostly because a long time ago you had to, at least on macOS classic). The system must be sending some sort of 'resources changed' signal to the engine that the linux engine is not handling or not handling well. I'll try to test this out on a some different Linux distro(s) later to see if maybe it's an MX Linux specific problem or a general linux problem.
User avatar
tperry2x
Posts: 1173
Joined: Tue Dec 21, 2021 9:10 pm
Location: Britain (Previously known as Great Britain)
Contact:

Re: Bug, with fonts when OXT is open.

Post by tperry2x »

Me too - I used to relaunch programs all the time to see new fonts. Libreoffice tends to need relaunching to see new fonts for example.
Back in the days of me using OS9 for work, we used to run Extensis Suitcase with it's various 'auto activation' extensions to achieve activation in programs without relaunching.
But yes, something seems to be tripping up OpenXTalk when the list of active fonts changes. Not sure what it is, but it really doesn't like it to cause such a spontaneous close. I'm happy to relaunch OpenXTalk, but because it crashes, I don't get any say in the matter - ultimately it gets relaunched, just not as gracefully as I'd like.
Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest