Editing interface graphic

Organizing tasks to work on, New Features Ideas, Building LCS & LCB Libraries & Widgets, Redecorating and Modifying the IDE, Hacking / Editing Tools, Compiling the Engine from Source, etc.
User avatar
richmond62
Posts: 3264
Joined: Sun Sep 12, 2021 11:03 am
Location: Bulgaria
Contact:

Re: Editing interface graphic

Post by richmond62 »

It works if you first insert an image area
Somehow counter-intuitive.
https://richmondmathewson.owlstown.net/
User avatar
tperry2x
Posts: 1981
Joined: Tue Dec 21, 2021 9:10 pm
Location: Somewhere in deepest darkest Norfolk, England
Contact:

Re: Editing interface graphic

Post by tperry2x »

I've fixed it. I've done this by automatically creating a suitable paint image if one doesn't exist (rather than letting it try to add one with it's flawed method). I need to test this on Windows and MacOS, but seems to be working on Linux so far...
(video here)
User avatar
richmond62
Posts: 3264
Joined: Sun Sep 12, 2021 11:03 am
Location: Bulgaria
Contact:

Re: Editing interface graphic

Post by richmond62 »

Incredible when you consider that 'that' was lying around unfixed from way, way back in time.

Presumably you'll roll that into 1.04?

Random word of the moment: Complacency.
https://richmondmathewson.owlstown.net/
User avatar
tperry2x
Posts: 1981
Joined: Tue Dec 21, 2021 9:10 pm
Location: Somewhere in deepest darkest Norfolk, England
Contact:

Re: Editing interface graphic

Post by tperry2x »

Yes, this will be part of OXT lite 1.04.
So, I suppose - getting back to the original point of this post: do I go with antialiased brushes?

I even thought about going mad and making some new anti-aliased bristly brushes. Or even any other shape. Suggestions welcome now we have it working.
User avatar
OpenXTalkPaul
Posts: 1871
Joined: Sat Sep 11, 2021 4:19 pm
Contact:

Re: Editing interface graphic

Post by OpenXTalkPaul »

micmac wrote: Mon Apr 22, 2024 2:38 pm It works if you first insert an image area

Mic
Correct, and I believe this is the main thing for fixing this bug, 'before mouseDown' the pencil/brush tool needs to ensure there is an existing, non-reference image or covert it to a non-reference image, or create a non-reference image, before drawing.

------EDIT just saw where Tom said he's fixed this.-------------

I'll have to check OXT DPE RC5 because I thought I tried to fix this at one point as well.

Also correct that this has been a bug for a long time and it was reported as a bug a long time ago too.

Over the weekend I've started working on OXT Tools palette again.
I spent some time looking at Tools palette from LC 7.x (pre-widgets), the tools palette had a couple different controller pop-up menus, for example the color selector was a grid of block, and there was a rounded corner radius selector that has since disappeared when the Tools was redesigned to include Widgets.
The tools palette is a 'script only' stack in v8-9 sections, the sections content and state is maintained by Arrays, which we can retrieve/manipulate. In v6-7 Tools is a regular stack.
Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests